Warning: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ..../includes/class_bootstrap.php(430) : eval()'d code on line 109
Need help from LS guru

Results 1 to 13 of 13
  1. #1
    49726 bronc j-8's Avatar
    Join Date
    Dec 2010
    Location
    Indian River
    Posts
    248

    Default Need help from LS guru

    Need help on a LS!
    Starts and runs great until I hit the gas. If you hold the throttle with steady pressure it revs to about 1340 rpms then it shuts off the injectors until about 950 rpms. Sounds just like a rev limiter, but way lower rpms.

    Motor is 2006 LS2. Intake, ECM& harness are 01-02
    Confirmed the motor is a 24x-4x crank and a 1x cam.
    Fuel pressure is good
    All sensors look like they are working on the lab scope
    ECM has all security deleted and is stand alone
    Even installed the ECM into a friends 00 pick-up and it works fine.
    Confirmed when it does this the spark is still good.

    I gave up and took it to a mechanic, now he is ready to give up.
    Please help! Invasion is coming up fast!
    1985 Scrambler LS2/NV4500/d300/D44s

  2. #2
    Big Orange Bomb!!! BigBird's Avatar
    Join Date
    Nov 2008
    Location
    Sault, Ontario
    Posts
    3,497

    Default

    I would look up waynehartwig on Pirate... I believe he is a go to guy for chevy tuning...

  3. #3
    49726 bronc j-8's Avatar
    Join Date
    Dec 2010
    Location
    Indian River
    Posts
    248

    Default

    Thanks. I will look him up.
    1985 Scrambler LS2/NV4500/d300/D44s

  4. #4
    toyota all the way Tacoma King's Avatar
    Join Date
    Feb 2008
    Location
    Sault ste. marie
    Posts
    1,052

    Default

    not to highjack a thread but waiting for tims RPMS rant
    Canadians who leave their Tim Hortons coffe all over walmart are pure evil.

  5. #5
    the real slim shady joescamaro67's Avatar
    Join Date
    Jan 2013
    Posts
    29

    Default

    Is the 06 crank sensor below the pass ex manifold or on the rear under the back of the intake ?

    I thought the 99-2003 were down low in the pass side and 24 count
    And the 06 was behind the intake ? Those were like a 58 count I think ?

    Where are u reading the tac from ? Dash or scanner ?

    Sounds like the computer thinks the motors revving more than it is?
    I would double check the tooth count
    NightKrawler is my HERO

  6. #6
    49726 bronc j-8's Avatar
    Join Date
    Dec 2010
    Location
    Indian River
    Posts
    248

    Default

    It is on passenger side behind the starter. Did a tooth count on cam & crank to verify. Crank is 24x and cam is 1x.
    I believe 2006 was an either or year on the reluctor wheel.
    I have tried the ECM in a different vehicle and it works fine.
    1985 Scrambler LS2/NV4500/d300/D44s

  7. #7
    Wannabe Jeep feva4u's Avatar
    Join Date
    Jun 2008
    Posts
    71

    Default

    Waynehartwig......psssssssshhhhhhhhhh He is alot better now than he was a couple years ago. I'll give him that.

  8. #8
    49726 bronc j-8's Avatar
    Join Date
    Dec 2010
    Location
    Indian River
    Posts
    248

    Default

    I found this guy👆
    1985 Scrambler LS2/NV4500/d300/D44s

  9. #9
    Wannabe Jeep feva4u's Avatar
    Join Date
    Jun 2008
    Posts
    71

    Default

    I think it runs now haha

  10. #10
    49726 bronc j-8's Avatar
    Join Date
    Dec 2010
    Location
    Indian River
    Posts
    248

    Default

    oooooh, does it ever! Thanks a ton. I hope dry pavement will hold cuz wet pavement sure wont.
    1985 Scrambler LS2/NV4500/d300/D44s

  11. #11
    I'm here for the fun whiterhino's Avatar
    Join Date
    May 2008
    Location
    Davisburg, MI
    Posts
    1,431

    Default

    Got it going? I was going to suggest the DBW module.

  12. #12
    Wannabe Jeep feva4u's Avatar
    Join Date
    Jun 2008
    Posts
    71

    Default

    Quote Originally Posted by whiterhino View Post
    Got it going? I was going to suggest the DBW module.
    It's running well enough to make that lq9 blush

  13. #13
    I'm here for the fun whiterhino's Avatar
    Join Date
    May 2008
    Location
    Davisburg, MI
    Posts
    1,431

    Default


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •